2019 Chevy Blazer Forum banner

21 - 38 of 38 Posts

·
Registered
Joined
·
4 Posts
Yes
I have a 2019 Blazer RS with the 21 inch wheels .My problem isnt with the tires.The car has 8000 miles on it ,is only 9 months old,and has been in the shop 3 times...currently where it is residing.The engine light will come on.Soon after that,taking off from a stop,the car will not shift out of 1st or 2nd gear...max speed is 25 mph.If the car is turned off for a bit and "rests" the trouble may happen,may not.The mechanic has only been able to duplicate the problem once making the fix difficult .Has anyone had this issue and,if so,how was it fixed.Currently the service manager is taking the car home for the weekend to see what happens,but since the engine codes have been cleared I dont feel real confident on the problem reoccurring. Oh yes,the dealership has a case open with GM.Probably should have waited for the 2020 Blazers but I needed a new car and,,after tons of research,picked my RS.
...
 

·
Registered
Joined
·
4 Posts
Mines a 2019 been in shop since 1-20 ... Can’t fix it ... No reverse Cold ... Reverse light indicator flashes 3 times .. No backup camera either when it acts up ... dealer has replace all modules and transmission... under 2000 miles ... GM is going to replace vehicle ...
 

·
Registered
Joined
·
13 Posts
[QUOTE="John Marshall, post: 10067, member:
Yes and thsnk you. 2020 Blazer 1LT 563 miles. Transmission failed. No over 25 miles. no reverse. Codes had transm fault. Towed. Out of State. Stranded. Motel. Rental car home. 38 days in shop. Parts all over the place. Asked GM to buy back. In BBB AutoLine program. A joke. 41 days and no resolution. BBB wants to start over. GM made offer i countered but crickets after i asked for loss of use payment and motel.
...
[/QUOTE]
 

·
Registered
Joined
·
13 Posts
Mines a 2019 been in shop since 1-20 ... Can’t fix it ... No reverse Cold ... Reverse light indicator flashes 3 times .. No backup camera either when it acts up ... dealer has replace all modules and transmission... under 2000 miles ... GM is going to replace vehicle ...
Service order and Mgr stated that they replaced throttle body. Get that jerking also. We might need class action if no buy back or loss pmt given. Sorry Cust Care. I was warned that GM sucks at cust care.
 

·
Registered
Joined
·
19 Posts
Service order and Mgr stated that they replaced throttle body. Get that jerking also. We might need class action if no buy back or loss pmt given. Sorry Cust Care. I was warned that GM sucks at cust care.
After sales customer care through GM is absolutely worthless. My Blazer was in the shop for 31 days and I received no help / info from GM and it took calling the dealerships general manager in order to get any answers
 

·
Registered
Joined
·
13 Posts
After sales customer care through GM is absolutely worthless. My Blazer was in the shop for 31 days and I received no help / info from GM and it took calling the dealerships general manager in order to get any answers
Yes
Same experience. 38 days. Called dealer cust care had no info!!
 

·
Registered
Joined
·
2 Posts
I just bought a new 2020 Blazer - it has 2500 miles on it - was a demo - day 2 of ownership it is now in the shop getting a new transmission put in. It had a really bad leak. I will update everyone once I get it back next week hopefully.
 

·
Registered
Joined
·
13 Posts
hi Mrobs, how is it going. My 2020 Blazer LT went in shop for transmission issue at 513 miles! 35 days loss of use (parts order, repair) Final GM agreement to fix 100K complete component coverage plus some expenses paid.
 

·
Registered
Joined
·
1 Posts
I have a 2019 Blazer RS with the 21 inch wheels .My problem isnt with the tires.The car has 8000 miles on it ,is only 9 months old,and has been in the shop 3 times...currently where it is residing.The engine light will come on.Soon after that,taking off from a stop,the car will not shift out of 1st or 2nd gear...max speed is 25 mph.If the car is turned off for a bit and "rests" the trouble may happen,may not.The mechanic has only been able to duplicate the problem once making the fix difficult .Has anyone had this issue and,if so,how was it fixed.Currently the service manager is taking the car home for the weekend to see what happens,but since the engine codes have been cleared I dont feel real confident on the problem reoccurring. Oh yes,the dealership has a case open with GM.Probably should have waited for the 2020 Blazers but I needed a new car and,,after tons of research,picked my RS.
I am experiencing the same issue... What was the resolution? My car - 2019 RS with 21,000 miles. 1 year old today. Engine light came on 4 times within the last 3 months - each time I brought to the dealer and they could not duplicate, except for one instance. They said they inadvertently "fixed" the issue...
 

·
Registered
Joined
·
4 Posts
Have a 2019 LT3 blazer with the V6 that has a jerking problem. It acts like the software tells the transmission move to 2nd gear, no 1st gear, no 2nd gear. It has also happens around 6th gear (guessing here) but dealer techs can't find an issue. No issue when Diagnostics is run. On the 5th trip to dealer I am told that is normal. Issue is most common in the lower gears.

Also have an issue on start-up and drive forward that results in a very pronounced jerking motion that the dealer tech denied experiencing; Until my 6th trip in when I am told that is normal as the car must Purge the air out of the system before driving. I should use my remote to start car so it has time to purge the air. The car is "working as designed." It also has the tendency to surge when you apply gas.

I also have one tire losing air, but nothing in the tire. I am having to put air in about once a week now. (21" low profile tires).

It also seems to have software issue and repeats it has a missing a SD card. I took 4 times of me turning car off and on to get it to clear on Christmas eve.

Anyone else seeing these issues?

Only thing positive is the nice ride when you get by the over issues.
I was having issues with my 2019 Blazer RS Cajun red and I took it into the dealer, because of the Warning Light came on telling me to have the “AWD Serviced.” I thought it was a System thing telling me it was time to have it serviced, because of the mileage. So when I took it into the dealership, they found that there was supposed to be a Factory update so 4 hrs later (Because the computer shut down before the update was finished) at 8:30 pm was told it would be another 50 minutes and afterwards I was told they would have to put in a NEW Differential, because the gears wasn’t going into the selective positions like AWD, Sport, Hauling, Normal etc. So, they had to order the parts, but I could take it home that evening though. My advisor said not to worry about it breaking down and if the Warning light doesn’t come on, I really didn’t need to bring it back to the dealership, but they called me like 2 days later and informed me the parts were in, so I took it back, because I don’t trust someone saying after they’ve told me there was a problem with the rear differential, but you don’t have to bring it back if there’s no warning lights! Anyway, once they replaced the Differential after 2days in the shop, driving it home I feel like a Vibration in the steering wheel and the Gear shifter. Now, I don’t remember if that feeling was there before or not. I know it’s a sports SUV mimicking the Camaro growl which I like very much, but I can’t remember if there was a vibration in the steering wheel and shifter or not. Anyway, I might be over-acting.
 

·
Registered
Joined
·
41 Posts
I was having issues with my 2019 Blazer RS Cajun red and I took it into the dealer, because of the Warning Light came on telling me to have the “AWD Serviced.” I thought it was a System thing telling me it was time to have it serviced, because of the mileage. So when I took it into the dealership, they found that there was supposed to be a Factory update so 4 hrs later (Because the computer shut down before the update was finished) at 8:30 pm was told it would be another 50 minutes and afterwards I was told they would have to put in a NEW Differential, because the gears wasn’t going into the selective positions like AWD, Sport, Hauling, Normal etc. So, they had to order the parts, but I could take it home that evening though. My advisor said not to worry about it breaking down and if the Warning light doesn’t come on, I really didn’t need to bring it back to the dealership, but they called me like 2 days later and informed me the parts were in, so I took it back, because I don’t trust someone saying after they’ve told me there was a problem with the rear differential, but you don’t have to bring it back if there’s no warning lights! Anyway, once they replaced the Differential after 2days in the shop, driving it home I feel like a Vibration in the steering wheel and the Gear shifter. Now, I don’t remember if that feeling was there before or not. I know it’s a sports SUV mimicking the Camaro growl which I like very much, but I can’t remember if there was a vibration in the steering wheel and shifter or not. Anyway, I might be over-acting.
The software on the RS is pretty trick and is a gen 1 of sorts. So updates and reliability issues will happen lol.
Once ur car is opened up that much, it will never be the same. I have a 2019 2lt awd and im starting to notice lag and problems at 14k miles. In the winter i hear the trans grinding, maybe a torque converter. But i work at a store and talked to a tech who said that once they take it all apart like that itll never be the same.... so ill wait haha.
 

·
Registered
Joined
·
41 Posts
I was having issues with my 2019 Blazer RS Cajun red and I took it into the dealer, because of the Warning Light came on telling me to have the “AWD Serviced.” I thought it was a System thing telling me it was time to have it serviced, because of the mileage. So when I took it into the dealership, they found that there was supposed to be a Factory update so 4 hrs later (Because the computer shut down before the update was finished) at 8:30 pm was told it would be another 50 minutes and afterwards I was told they would have to put in a NEW Differential, because the gears wasn’t going into the selective positions like AWD, Sport, Hauling, Normal etc. So, they had to order the parts, but I could take it home that evening though. My advisor said not to worry about it breaking down and if the Warning light doesn’t come on, I really didn’t need to bring it back to the dealership, but they called me like 2 days later and informed me the parts were in, so I took it back, because I don’t trust someone saying after they’ve told me there was a problem with the rear differential, but you don’t have to bring it back if there’s no warning lights! Anyway, once they replaced the Differential after 2days in the shop, driving it home I feel like a Vibration in the steering wheel and the Gear shifter. Now, I don’t remember if that feeling was there before or not. I know it’s a sports SUV mimicking the Camaro growl which I like very much, but I can’t remember if there was a vibration in the steering wheel and shifter or not. Anyway, I might be over-acting.
Honestly, dont worry about the little vibrations. 310hp and its so fun to drive lol. Get the magnaflow exhaust!
 

·
Registered
Joined
·
2 Posts
Hey, I have just noticed that hesitation. Plus, the Rear camera monitor will not turn off rear view display for a few seconds after going in Drive!

Another issue:This car was in shop for over 30 days (36) and Dealer Service said they fixed the transmission issue of that 25 MPH only and no Reverse after 500 miles, (Dealer said the fix was a throttle body rebuild, no parts, had to wait for parts from different locations!) . Anyone else have any transmission related issues with new 2020 Blazer? Thanks!

new 1LT, 2020 Blazer now at over 1200 miles
 

·
Registered
Joined
·
2 Posts
2020 Blazer Redline edition just hit 10,000 mile mark and transmission went. Been in the shop for almost 3 weeks and still no replacement transmission.....these vehicles are way to expensive to have these problems so early on. Faithful GM owner for 25 years but maybe no more. Husband has 2019 GMC Sierra AT4 that motor went in first year also.
 

·
Registered
Joined
·
6 Posts
I have a 2019 Blazer RS with the 21 inch wheels .My problem isnt with the tires.The car has 8000 miles on it ,is only 9 months old,and has been in the shop 3 times...currently where it is residing.The engine light will come on.Soon after that,taking off from a stop,the car will not shift out of 1st or 2nd gear...max speed is 25 mph.If the car is turned off for a bit and "rests" the trouble may happen,may not.The mechanic has only been able to duplicate the problem once making the fix difficult .Has anyone had this issue and,if so,how was it fixed.Currently the service manager is taking the car home for the weekend to see what happens,but since the engine codes have been cleared I dont feel real confident on the problem reoccurring. Oh yes,the dealership has a case open with GM.Probably should have waited for the 2020 Blazers but I needed a new car and,,after tons of research,picked my RS.
Hi. My car is having same issue (won’t come out of 1st gear) along with low fuel light coming on and parking break light, traction control light as well) Its with drake now and they can’t replicate. How was your issue resolved at dealer? Thanks
 

·
Registered
Joined
·
6 Posts
I have a 2019 Blazer RS with the 21 inch wheels .My problem isnt with the tires.The car has 8000 miles on it ,is only 9 months old,and has been in the shop 3 times...currently where it is residing.The engine light will come on.Soon after that,taking off from a stop,the car will not shift out of 1st or 2nd gear...max speed is 25 mph.If the car is turned off for a bit and "rests" the trouble may happen,may not.The mechanic has only been able to duplicate the problem once making the fix difficult .Has anyone had this issue and,if so,how was it fixed.Currently the service manager is taking the car home for the weekend to see what happens,but since the engine codes have been cleared I dont feel real confident on the problem reoccurring. Oh yes,the dealership has a case open with GM.Probably should have waited for the 2020 Blazers but I needed a new car and,,after tons of research,picked my RS.
I’m having these same issues and dealer did not find any codes in computer ( even though I showed them pics of warning lights that came on) on my first service call for this issue and returned the car to me with no repaired performed. I now have another appointment with dealer for this same issue. Was dealer able to finally resolve this issue for you? Can you tell me what repair they performed?
 
21 - 38 of 38 Posts
Top