2019 Chevy Blazer Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2019 Blazer RS since the end of April. This blazer has the 5 trans setting AWD, sport awd, hill, trailer and 2wd. it has 4,000 miles on the car and all of the sudden the service all wheel drive light comes on. This warning light came on when we were in 2wd. The blazer is at the dealership right now. Cannot expect them to last forever. Has anyone had this issue yet?
181
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
So the dealership called and it needs a new - rear differential control module.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks for sharing both the issue and the resolution.
So, the dealership put the new module on and the warning light came back last night. It is scheduled to go back to the dealership on tuesday. I will repost with new details as I get them.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
They hooked the blazer back up to the computer and it said bad module again. They ran some more test and still no answer to the problem. So, they moved up the chain and called an engineer at GM an ran through everything again. It came down to the wiring that plugged into the module. They replaced the wire and made sure all connections were clean. It has fixed the problem.
 

·
Registered
Joined
·
2 Posts
I have a 2019 Blazer RS since the end of April. This blazer has the 5 trans setting AWD, sport awd, hill, trailer and 2wd. it has 4,000 miles on the car and all of the sudden the service all wheel drive light comes on. This warning light came on when we were in 2wd. The blazer is at the dealership right now. Cannot expect them to last forever. Has anyone had this issue yet? View attachment 181
I'm really glad you posted this. I also have a 2019 Blazer RS with 3600 miles and the same thing happened in mine today. I will be calling my dealership tomorrow and referencing your issue/resolution. Thanks for sharing!
And by the way your Blazer is stunning! Mine is white and I love it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
I'm really glad you posted this. I also have a 2019 Blazer RS with 3600 miles and the same thing happened in mine today. I will be calling my dealership tomorrow and referencing your issue/resolution. Thanks for sharing!
And by the way your Blazer is stunning! Mine is white and I love it.
I hope everything works out for you. We ended up getting our module replaced a total of 3 times and wiring the last one seems to be doing what it is supposed to. We know have a case file setup with GM and if it happens again they are sending a GM Engineer to our local dealership to work on the issue.
When we purchased they had White and our color, it was hard to choose between them. We love our Blazer and everything has worked out so far.
 

·
Registered
Joined
·
2 Posts
I hope everything works out for you. We ended up getting our module replaced a total of 3 times and wiring the last one seems to be doing what it is supposed to. We know have a case file setup with GM and if it happens again they are sending a GM Engineer to our local dealership to work on the issue.
When we purchased they had White and our color, it was hard to choose between them. We love our Blazer and everything has worked out so far.
Yes, your color would have been runner up for me, I love it. The RS is the nicer looking option for sure.
So, the service message is gone in mine now and the AWD light is back on but I'm taking it in this week anyway to run the code history.
Enjoy your beautiful Blazer!
 

·
Registered
Joined
·
9 Posts
WOW you want to hear my story about the AWD light....Lets start

bought the car back in sept 2019....2 weeks into having the car start getting rattles from the back seat...which i did post on here...anyways that was takin care off which lasted about a month...October rolls in and i get the AWD service soon on the dash...so i take it in and told them about the AWD and the rattling...left the car there so they can do their thing...get the call back that they ordered the part for the AWD and fixed the rattling again...3 months later driving and waiting for the part which is now almost Christmas my oil change was coming up but still no parts came in to fix the AWD....had no choice but to bring it into the dealer for the oil change...asked the adviser " Its been now 3 months and no part still..who do i need to escalate to?!?!" the guy said let me call another dealer to see if they have the part...now am like WTF you mean so why did i wait 3 months for...anyways they called me back and said we changed the oil but the part we got didn't fix the issue...so they put me in a rental...this is now mid Jan i got this rental...2 months driving the rental from Jan to end of Feb 2020 they finally got the part and replaced the transfer case actuator, rear differential clutch control module and a bunch of other parts...i finally got back my car...so basically i was out of a working car for 5 months and making payments to car i couldn't use... it was total BS..
 

·
Registered
Joined
·
54 Posts
WOW you want to hear my story about the AWD light....Lets start

bought the car back in sept 2019....2 weeks into having the car start getting rattles from the back seat...which i did post on here...anyways that was takin care off which lasted about a month...October rolls in and i get the AWD service soon on the dash...so i take it in and told them about the AWD and the rattling...left the car there so they can do their thing...get the call back that they ordered the part for the AWD and fixed the rattling again...3 months later driving and waiting for the part which is now almost Christmas my oil change was coming up but still no parts came in to fix the AWD....had no choice but to bring it into the dealer for the oil change...asked the adviser " Its been now 3 months and no part still..who do i need to escalate to?!?!" the guy said let me call another dealer to see if they have the part...now am like WTF you mean so why did i wait 3 months for...anyways they called me back and said we changed the oil but the part we got didn't fix the issue...so they put me in a rental...this is now mid Jan i got this rental...2 months driving the rental from Jan to end of Feb 2020 they finally got the part and replaced the transfer case actuator, rear differential clutch control module and a bunch of other parts...i finally got back my car...so basically i was out of a working car for 5 months and making payments to car i couldn't use... it was total BS..
This does not surprise me as it was during the GM strike. No dealerships could get parts, they had no clue when they would get stuff and it was hard to let customers know. It was a shit show. I'd say you got lucky that they let you have a rental for that long. Look at it this way.. you didn't have to put 2 months of miles onto your Blazer and used a car for 2 months free. (At least I hope they let you use it free.) I've heard of worse scenarios.
 
1 - 12 of 12 Posts
Top