2019 Chevy Blazer Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Got into my blazer today ( has 4000 miles ) and the infotainment center doesn’t work. No radio, backup camera, etc. Charger doesn’t work and the hazards and turn signals do not make noise. I’m so frustrated. Already waiting for a new bumper because the hatch cover would not stay shut.
 

·
Registered
Joined
·
107 Posts
i had the screen freeze within the first week. Dont think this ever happened on my 2017 acadia. Both times it stopped without me taking any action. Not good- we'll see if it persists
 

·
Registered
Joined
·
107 Posts
There are a few TSBs for the infotainment system. After reading them I looked at the software version in my car and lo and behold it was updated in October before I ever took delivery- and yet the freezing continues. So it must not be a software problem.
 

·
Registered
Joined
·
78 Posts
Knock-on-wood... I haven't had any issues other than Apple Carplay not recognizing my phone on one trip. I moved the cable to the port in the armrest and haven't had an issue since (again knocking on wood...) I hope you got your issue resolved.
 

·
Registered
Joined
·
107 Posts
Knock-on-wood... I haven't had any issues other than Apple Carplay not recognizing my phone on one trip. I moved the cable to the port in the armrest and haven't had an issue since (again knocking on wood...) I hope you got your issue resolved.
thanks, dealer visit Tuesday. I'm not optimistic now that I see the software is actually current! Since this current system is shared by many 2018/19 GM vehicles I wonder if these issues are isolated to Blazer or endemic to the new interface.
 

·
Registered
Joined
·
107 Posts
went to dealer- they said nothing is wrong with my car- not even sure if they actually looked into the situation- just said they couldnt duplicate the condition- even though it happened on my way to the appointment.
 

·
Registered
Joined
·
78 Posts
Sounds like a typical dealership service visit... :rolleyes: Sorry they couldn’t figure it out.
 

·
Registered
Joined
·
107 Posts
since I was last here my car was at dealer for a week and during that time they tried a software update and that didn't fix the freezing when the car was cold. They kept it an extra day and replaced the radio module (which seems to include the screen) and so far so good.
 

·
Registered
Joined
·
1 Posts
Similar issue, 2020 Blazer, 1200 miles. On two occasions, after starting the car I have no sound from radio or any other sounds like directional sounds. Everything else seems to work. Restarting the car has resolved the issue both times. I will monitor this thread to see if this is a frequent problem with other owners.
 

·
Registered
Joined
·
107 Posts
Similar issue, 2020 Blazer, 1200 miles. On two occasions, after starting the car I have no sound from radio or any other sounds like directional sounds. Everything else seems to work. Restarting the car has resolved the issue both times. I will monitor this thread to see if this is a frequent problem with other owners.
I didnt have that exact issue, but similarly my issue would last for several minutes after startup and then go away. Since they replaced the radio module I have had no issues.
 

·
Registered
Joined
·
2 Posts
What did you do to fix this?


Similar issue, 2020 Blazer, 1200 miles. On two occasions, after starting the car I have no sound from radio or any other sounds like directional sounds. Everything else seems to work. Restarting the car has resolved the issue both times. I will monitor this thread to see if this is a frequent problem with other owners.
[/QUOTE
 

·
Registered
Joined
·
5 Posts
went to dealer- they said nothing is wrong with my car- not even sure if they actually looked into the situation- just said they couldnt duplicate the condition- even though it happened on my way to the appointment.
I had this same problem! Last visit they told me it would take a month of it sitting there for them to diagnose the problem.
mine has been in the shop more than five times for same issue. And I was with out my car for over 40 days.
In the process of trying to invoke the lemon law. Has anyone else had any luck with this??
 

·
Registered
Joined
·
5 Posts
went to dealer- they said nothing is wrong with my car- not even sure if they actually looked into the situation- just said they couldnt duplicate the condition- even though it happened on my way to the appointment.
I had this same problem! Last visit they told me it would take a month of it sitting there for them to diagnose the problem.
mine has been in the shop more than five times for same issue. And I was with out my car for over 40 days.
In the process of trying to invoke the lemon law. Has anyone else had any luck with this??
 

·
Registered
Joined
·
107 Posts
I had this same problem! Last visit they told me it would take a month of it sitting there for them to diagnose the problem.
mine has been in the shop more than five times for same issue. And I was with out my car for over 40 days.
In the process of trying to invoke the lemon law. Has anyone else had any luck with this??
They replaced my radio module and no issues since. Not sure why your dealer hasn't suggested this
 

·
Registered
Joined
·
3 Posts
Got into my blazer today ( has 4000 miles ) and the infotainment center doesn’t work. No radio, backup camera, etc. Charger doesn’t work and the hazards and turn signals do not make noise. I’m so frustrated. Already waiting for a new bumper because the hatch cover would not stay shut.
 

·
Registered
Joined
·
2 Posts
My 2019, bought new in May, is now doing this regularly. Has anyone else gotten a reasonable fix or just the person who got a whole new radio console?
 

·
Registered
Joined
·
3 Posts
Had to have a brand new entertainment system put in so far fingers crossed has been great. No problems since the new installation . Try the dealership again. For a new one
 
1 - 20 of 24 Posts
Top