2019 Chevy Blazer Forum banner

Hard brake pedal at startup

681 Views 3 Replies 3 Participants Last post by  Kim'sBlazer
I've noticed the last couple days with this artic cold blast that the northern half of us are experiencing that after the car sits for hours, like at work or over night, that when I go to start the vehicle that my brake pedal is very hard, almost will not move. I am able to start the vehicle and after it starts the pedal feels normal again. Anyone else notice this is this cold weather?
1 - 4 of 4 Posts
Happens to me also. Even in warm weather, if you let the car sit for days this will happen. No idea if it’s an issue or if there is a fix.
Happens to me also. Even in warm weather, if you let the car sit for days this will happen. No idea if it’s an issue or if there is a fix.
Here is some added info from driving the last couple days. I notice if I do short trips in the cold weather where the car really does not warm up I will experience this. Now yesterday I was doing alot of driving where the car warmed up and this morning no issues. So I'm wondering if moisture is getting in the brake booster or something and with the car not getting warm it freezes. Just a thought.
I've noticed the last couple days with this artic cold blast that the northern half of us are experiencing that after the car sits for hours, like at work or over night, that when I go to start the vehicle that my brake pedal is very hard, almost will not move. I am able to start the vehicle and after it starts the pedal feels normal again. Anyone else notice this is this cold weather?
1 - 4 of 4 Posts
Top