2019 Chevy Blazer Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
so i’ve got a 1994 chevy s10 blazer 4x4 with a 4.3l vortec motor, i was getting horrible fuel mileage and i heard the spider injectors give out in these a lot so i replaced it and it defenitely needed to be replaced, afterwards it ran smooth for a day or two then i started to get a rough idle and strong gas smell and some hiccuping from time to time while idling, after driving for about 10 minutes the cars rough idle goes away and no more hiccups but still a strong fuel smell, anybody know what the issue could be ive replaced the EGR valve and maf sensor and spark plugs thinking it would help but nothing seems to work.
tplinklogin
https://pincodes.gen.in/
 

·
Registered
Joined
·
28 Posts
so i’ve got a 1994 chevy s10 blazer 4x4 with a 4.3l vortec motor, i was getting horrible fuel mileage and i heard the spider injectors give out in these a lot so i replaced it and it defenitely needed to be replaced, afterwards it ran smooth for a day or two then i started to get a rough idle and strong gas smell and some hiccuping from time to time while idling, after driving for about 10 minutes the cars rough idle goes away and no more hiccups but still a strong fuel smell, anybody know what the issue could be ive replaced the EGR valve and maf sensor and spark plugs thinking it would help but nothing seems to work.
You'd be better off at www.s10forum.com. They deal with the 1st and 2nd gen S10's.
 
1 - 2 of 2 Posts
Top