2019 Chevy Blazer Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
I just purchased my 2021 Blazer RS, and the dash started acting up, 3000 miles.

It's like the truck is turning off as I'm driving, but it doesn't feel like it. It did it going 45mph, 20, and in Park.

All other electronics work except the auto shut off feature.

 

·
Registered
Joined
·
9 Posts
What did Chevy do to fix this issue ? Mine starting doing same thing - I have 2021 Blazer RS - and I’m right at 2800 miles
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
What did Chevy do to fix this issue ? Mine starting doing same thing - I have 2021 Blazer RS - and I’m right at 2800 miles
They couldn't get it to replicate, but luckily I had the videos.

They replaced the instrument cluster. That night and next morning was the only time it acted up. It never happened again. Either, while I was waiting for the parts to arrive or after install.
 

·
Registered
Joined
·
9 Posts
They couldn't get it to replicate, but luckily I had the videos.

They replaced the instrument cluster. That night and next morning was the only time it acted up. It never happened again. Either, while I was waiting for the parts to arrive or after install.
Thank you so much for replying - taking mine in tomorrow for them to look at
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thank you so much for replying - taking mine in tomorrow for them to look at
No problem. I hope they are able to resolve it.
If it ends up being something different, let me know. That way if it happens again, I can bring it up.
 

·
Registered
Joined
·
9 Posts
No problem. I hope they are able to resolve it.
If it ends up being something different, let me know. That way if it happens again, I can bring it up.
So I got my vehicle back and they replaced the exact same thing you said they did to yours - they couldn’t get it to replicate and I had sowed them out Covid so they just did the same as what they did for you

what did these mechanics and dealerships do before there were customer forums to bring answers back to them ? I know they probably would’ve sent me back home and not did anything -unfortunately - we will see what happens come next winter and the cold
 

·
Registered
Joined
·
2 Posts
Had my 2021 RS for about a month now 1350 miles and it is doing the same thing. Glad to know it isn’t just me. Will be showing them this thread when I take it in on Wednesday.
 

·
Registered
Joined
·
2 Posts
Had my 2021 RS for about a month now 1350 miles and it is doing the same thing. Glad to know it isn’t just me. Will be showing them this thread when I take it in on Wednesday.
Does the vehicle itself shut off or just the dash board goes dark? Mine did it this morning as well and I'm hoping it doesn't do it again but am curious if it was just the dash and didn't shut off the engine. Thanks much!
 

·
Registered
Joined
·
9 Posts
Had my 2021 RS for about a month now 1350 miles and it is doing the same thing. Glad to know it isn’t just me. Will be showing them this thread when I take it in on Wednesday.
So far after they replace those modules in dash - it seems to have corrected the issue - so far .... stay tuned for when weather gets super cold again
 

·
Registered
Joined
·
2 Posts
Does the vehicle itself shut off or just the dash board goes dark? Mine did it this morning as well and I'm hoping it doesn't do it again but am curious if it was just the dash and didn't shut off the engine. Thanks much!
Other than the dash going out, nothing else seems to be affected. No issues with the car running and the service manager told me that it was perfectly safe to drive (implied it was not the first time he’d seen this issue).
 

·
Registered
Joined
·
2 Posts
Other than the dash going out, nothing else seems to be affected. No issues with the car running and the service manager told me that it was perfectly safe to drive (implied it was not the first time he’d seen this issue).
Thanks so much for the response. When I called my dealer this morning they said they had never heard of the issue (yeah) and couldn't do anything unless they could duplicate the issue. Hopefully this is a 'do it twice and be done with it' kind of thing. Thanks again!
 

·
Registered
Joined
·
9 Posts
Thanks so much for the response. When I called my dealer this morning they said they had never heard of the issue (yeah) and couldn't do anything unless they could duplicate the issue. Hopefully this is a 'do it twice and be done with it' kind of thing. Thanks again!
I had the thought very quickly to whip my cell phone out and record it so I could show dealer service Dept - and I took a copy of convo on this forum of what another dealer did abs showed them that as well - I knew the service sept would say exactly what you’ve stated - “can’t replicate - can’t fix - that’s BS
 
1 - 12 of 12 Posts
Top