2019 Chevy Blazer Forum banner
21 - 21 of 21 Posts

·
Registered
Joined
·
1 Posts
I have a 2021 Blazer 2LT with the 3.6L and AWD options fitted on it. I took delivery in November '21 and noticed a couple things in the few months since owning that I wanted to get some opinions on here about to know if its a common occurrence/normal or something worth bringing up when I take to the dealership later this month to get a window scratch fixed. Here's what I've noticed:
  • It's only happened to me a couple of times and usually when I apply moderate to heavy force on my brake pedal, but there will be a grinding noise that comes from the wheels while coming to a stop. I don't notice any visible gouges or scratches to the rotors but have heard from one other person that their brake pads were faulty from the factory and he had to go them fixed at a dealer. Has anyone else had this problem? Is this more common than I think?
  • for the AWD models, I know that these Blazers will remember if your are in X2 or X4 mode whenever you turn off and restart the vehicle, but whenever I'm in sport, trail, or tow mode and shut the vehicle off, it defaults back to X2 mode. is this true for everyone else?
  • I know that almost all (if not all) new vehicles today have an electronically controlled throttle, but the tachometer seems to lag a bit whenever I'm accelerating quickly. For example, if im in a highway gear coasting at around 2000 rpm and trying to pass someone, I accelerate pretty quickly and can feel/hear the engine accelerating but the needle on the tachometer wont budge from 2000 rpm until the engine gets to 3000 rpm and then it'll suddenly jerk over to reflect the correct rpms. Is this common for these vehicles? Does anyone else notice the same thing?
  • I don't have the Driver confidence and convenience package on my vehicle or whichever package it is that upgrades you to a BOSE sound system throughout the car. The non-bose factory speakers in the door panels seem to suck and have a lot of static noise whenever a song with mid to high level bass is played. is this just poor quality speakers or is mine possibly faulty?
Has anyone had any issues with the gas pedal grinding/vibrating's, especially in sport mode? (I notice it more going over mountains/corners)
 
21 - 21 of 21 Posts
Top