2019 Chevy Blazer Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
2019 blazer RS with 20k Miles. 3 days ago, the check engine light came on, car wouldn’t come out of 1st gear, service parking brake light popped up, service traction control light, and then random low fuel alert when there was over 1/2 tank of gas. I let the car sit for an hour, took it around the block and it came out of 1st gear but all the warning lights remained. Then today, check engine light is gone and no other alerts are present. It’s going to the dealership on Monday, but it’s super frustrating. Anyone else experienced anything like this?
 

·
Registered
Joined
·
3 Posts
Currently dealing with this !!! They can’t get me in the shop for 3 weeks. Did you ever find out what caused this ??

2019 blazer RS with 20k Miles. 3 days ago, the check engine light came on, car wouldn’t come out of 1st gear, service parking brake light popped up, service traction control light, and then random low fuel alert when there was over 1/2 tank of gas. I let the car sit for an hour, took it around the block and it came out of 1st gear but all the warning lights remained. Then today, check engine light is gone and no other alerts are present. It’s going to the dealership on Monday, but it’s super frustrating. Anyone else experienced anything like this?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Currently dealing with this !!! They can’t get me in the shop for 3 weeks. Did you ever find out what caused this ??
It was a “software update” which is pretty much code for them having no clue. They updated the software and all was fine for about a month. Then the same thing happened again and the entire ABS system needed replaced. Hopefully you have better luck than I did with your first service appointment.
 

·
Registered
Joined
·
3 Posts
It was a “software update” which is pretty much code for them having no clue. They updated the software and all was fine for about a month. Then the same thing happened again and the entire ABS system needed replaced. Hopefully you have better luck than I did with your first service appointment.
Oh my gosh… this is my second time having to take it to the shop. The first time I took it, they had it for 2 weeks and finally came to the conclusion that the dash had been recalled. But there’s still no replacement for it, so I’ve been driving it with no analog speedometer (luckily we have the digital)… I’ve had it 3 months and feel like I keep having to call service about it!
 

·
Registered
Joined
·
4 Posts
We had a similar issue with our 2021Blazer. Check engine light would come on. Then transmission would not shift. Left my wife stranded having to get towed 3 times before it was finally fixed. First time they had it 10 days saying it was a software issue. Second time they had it 8 days and replaced a shift sensor. Third time 8 days again. I tried getting GM to buy it back. They said if it isn’t fixed on 3rd try that they would start the process of a buy back. They finally had a factory adviser look into it. It was a pinched wiring harness. We have not had any issues since the repair. But for awhile they we had serious regret. Lol
 

·
Registered
Joined
·
17 Posts
Oh my gosh… this is my second time having to take it to the shop. The first time I took it, they had it for 2 weeks and finally came to the conclusion that the dash had been recalled. But there’s still no replacement for it, so I’ve been driving it with no analog speedometer (luckily we have the digital)… I’ve had it 3 months and feel like I keep having to call service about it!
I had a 2021 and it was in the shop 13 times in 8 months. 10,000 miles on it and my dealer screwed me over on it
 

·
Registered
Joined
·
3 Posts
We had a similar issue with our 2021Blazer. Check engine light would come on. Then transmission would not shift. Left my wife stranded having to get towed 3 times before it was finally fixed. First time they had it 10 days saying it was a software issue. Second time they had it 8 days and replaced a shift sensor. Third time 8 days again. I tried getting GM to buy it back. They said if it isn’t fixed on 3rd try that they would start the process of a buy back. They finally had a factory adviser look into it. It was a pinched wiring harness. We have not had any issues since the repair. But for awhile they we had serious regret. Lol
Im definitely feeling the regret LOL. They’ve had it since last Tuesday (9 days).On Friday we were told that it was the instrumental cluster and that the guy would be in on Monday to fix it… when they guy came in on Monday, he hooked the scanner back to it and couldn’t pull any codes. He’s been driving it since Monday this week trying to get it to throw all of the warning lights again and has been unsuccessful. We’ve now been told that we will have to pick it up this Friday and drive it until it happens again.
 

·
Registered
Joined
·
17 Posts
Im definitely feeling the regret LOL. They’ve had it since last Tuesday (9 days).On Friday we were told that it was the instrumental cluster and that the guy would be in on Monday to fix it… when they guy came in on Monday, he hooked the scanner back to it and couldn’t pull any codes. He’s been driving it since Monday this week trying to get it to throw all of the warning lights again and has been unsuccessful. We’ve now been told that we will have to pick it up this Friday and drive it until it happens again.
They put a new instrument cluster in mine did not help. GM refused to buy it back and my dealer would not even give me payoff. My lights would flash the hatch would just raise itself. I have videos and they still wouldn’t help me
 
1 - 8 of 8 Posts
Top