2019 Chevy Blazer Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Purchased brand new 2020 Chevy Blazer RS twenty days ago and the rear, front and side cameras stopped working. When in Reverse it display an exclamation mark and a camera sign with red circle. Can anyone help if it is a setting issue or anything i can try myself to fix this.
 

·
Registered
Joined
·
78 Posts
I doubt it's a setting. Sounds like something broke. Maybe a fuse blew. First I'd find and look at the fuse that the cameras are powered by. If that is good, I'd bring it to the dealership.
 

·
Registered
Joined
·
12 Posts
I’d say take it to the dealer. This is the first of many problems you may experience. I have a 2019 with 9000 miles and it’s been in the shop 45 days waiting on a computer part.
 

·
Registered
Joined
·
14 Posts
Purchased brand new 2020 Chevy Blazer RS twenty days ago and the rear, front and side cameras stopped working. When in Reverse it display an exclamation mark and a camera sign with red circle. Can anyone help if it is a setting issue or anything i can try myself to fix this.
At the LEAST, call the Dealer's Service Dept & ask them? They may have the answer or tell you to bring it in. They know more about your Blazer's Features than most people. It IS under Warranty.
 

·
Registered
Joined
·
5 Posts
Purchased brand new 2020 Chevy Blazer RS twenty days ago and the rear, front and side cameras stopped working. When in Reverse it display an exclamation mark and a camera sign with red circle. Can anyone help if it is a setting issue or anything i can try myself to fix this.
We bought a 2020 Blazer and experienced (after just three weeks) the same problem. We had the same exclamation mark and red circle. We brought it back to the dealer and they replaced the camera. It started to work again but after 10 tests, it stopped working again. They had to order a new video processing unit but that part was on "back order." If the part is on back order, does that mean they have had numerous problems with this part? They did receive the new part and installed it. They had our car for 10 days. So far, just over three weeks, and it has been working without a problem. I did see in the news that Ford and Honda were recalling cars because of camera problems. I wonder if the camera units are manufactured from the same company. Good luck, and let us know how it goes with your Blazer.
 

·
Registered
Joined
·
2 Posts
We bought a 2020 Blazer and experienced (after just three weeks) the same problem. We had the same exclamation mark and red circle. We brought it back to the dealer and they replaced the camera. It started to work again but after 10 tests, it stopped working again. They had to order a new video processing unit but that part was on "back order." If the part is on back order, does that mean they have had numerous problems with this part? They did receive the new part and installed it. They had our car for 10 days. So far, just over three weeks, and it has been working without a problem. I did see in the news that Ford and Honda were recalling cars because of camera problems. I wonder if the camera units are manufactured from the same company. Good luck, and let us know how it goes with your Blazer.
I worked for a chevy dealer in Maryland and what i was told by our parts department manager was that we don't keep high dollar amount parts on hand because those are purchased out of the dealers pocket and they won't order it just incase someone will randomly order it... but most computer parts are not made in the usa for chevy.
Haven't had any of these issues (yet) with my 2019 blazer.
 
1 - 6 of 6 Posts
Top