2019 Chevy Blazer Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Purchased brand new 2020 Chevy Blazer RS twenty days ago and the rear, front and side cameras stopped working. When in Reverse it display an exclamation mark and a camera sign with red circle. Can anyone help if it is a setting issue or anything i can try myself to fix this.
 

· Registered
Joined
·
109 Posts
I doubt it's a setting. Sounds like something broke. Maybe a fuse blew. First I'd find and look at the fuse that the cameras are powered by. If that is good, I'd bring it to the dealership.
 

· Registered
Joined
·
30 Posts
Purchased brand new 2020 Chevy Blazer RS twenty days ago and the rear, front and side cameras stopped working. When in Reverse it display an exclamation mark and a camera sign with red circle. Can anyone help if it is a setting issue or anything i can try myself to fix this.
At the LEAST, call the Dealer's Service Dept & ask them? They may have the answer or tell you to bring it in. They know more about your Blazer's Features than most people. It IS under Warranty.
 

· Registered
Joined
·
6 Posts
Purchased brand new 2020 Chevy Blazer RS twenty days ago and the rear, front and side cameras stopped working. When in Reverse it display an exclamation mark and a camera sign with red circle. Can anyone help if it is a setting issue or anything i can try myself to fix this.
We bought a 2020 Blazer and experienced (after just three weeks) the same problem. We had the same exclamation mark and red circle. We brought it back to the dealer and they replaced the camera. It started to work again but after 10 tests, it stopped working again. They had to order a new video processing unit but that part was on "back order." If the part is on back order, does that mean they have had numerous problems with this part? They did receive the new part and installed it. They had our car for 10 days. So far, just over three weeks, and it has been working without a problem. I did see in the news that Ford and Honda were recalling cars because of camera problems. I wonder if the camera units are manufactured from the same company. Good luck, and let us know how it goes with your Blazer.
 

· Registered
Joined
·
3 Posts
We bought a 2020 Blazer and experienced (after just three weeks) the same problem. We had the same exclamation mark and red circle. We brought it back to the dealer and they replaced the camera. It started to work again but after 10 tests, it stopped working again. They had to order a new video processing unit but that part was on "back order." If the part is on back order, does that mean they have had numerous problems with this part? They did receive the new part and installed it. They had our car for 10 days. So far, just over three weeks, and it has been working without a problem. I did see in the news that Ford and Honda were recalling cars because of camera problems. I wonder if the camera units are manufactured from the same company. Good luck, and let us know how it goes with your Blazer.
I worked for a chevy dealer in Maryland and what i was told by our parts department manager was that we don't keep high dollar amount parts on hand because those are purchased out of the dealers pocket and they won't order it just incase someone will randomly order it... but most computer parts are not made in the usa for chevy.
Haven't had any of these issues (yet) with my 2019 blazer.
 

· Registered
Joined
·
12 Posts
I doubt it's a setting. Sounds like something broke. Maybe a fuse blew. First I'd find and look at the fuse that the cameras are powered by. If that is good, I'd bring it to the dealership.
Why not suggest he bring it back to the dealer since it's still under warranty instead of going to the hassle of locating a fuse?
 

· Registered
2022 Blazer RS V6 Black
Joined
·
70 Posts
If it's under warranty, I surely wouldn't go messing around troubleshooting in the fusebox. I'd take it to the dealer and let them do their thang. The last thing you want is to jack it up even more and give them a reason to reject your claim. Even though it may be a simple fix by replacing a fuse, you might find yourself down the rabbit hole and lost and spaced.
 

· Registered
Joined
·
109 Posts
lol... A lot of people are comfortable doing things themselves and come to sites like these looking for advice. This person came here asking if there was something they could look at. I gave the absolute simplest of suggestions and said if that's OK, to go to the dealer. It's not like I told them to take their dashboard apart. If you want to tell them to go to the dealership, that's great. Do so. But why call out someone that gave the simplest of advice? What does that accomplish besides discouraging others to give advice in the future or even come to sites like this?
 

· Registered
2022 Blazer RS V6 Black
Joined
·
70 Posts
lol... A lot of people are comfortable doing things themselves and come to sites like these looking for advice. This person came here asking if there was something they could look at. I gave the absolute simplest of suggestions and said if that's OK, to go to the dealer. It's not like I told them to take their dashboard apart. If you want to tell them to go to the dealership, that's great. Do so. But why call out someone that gave the simplest of advice? What does that accomplish besides discouraging others to give advice in the future or even come to sites like this?
You're right, he did ask for help, but I think you're reading into something that's not there. No reason to get defensive. As you said, lots of people come here to ask for and give advice, but that doesn't mean anyone is being attacked for their given advice. I give you the same grace that I would hope to be given, so please don't read into something that's not there. Your input is valuable and deserves the same respect as the next one that posts. Sometimes the written word can be taken out of context, especially on the interwebs. Isn't that kinda what's wrong with all this crazy crap in the world? Everyone wants to talk, yet no one can be heard.

It's all good
 

· Registered
Joined
·
32 Posts
Purchased brand new 2020 Chevy Blazer RS twenty days ago and the rear, front and side cameras stopped working. When in Reverse it display an exclamation mark and a camera sign with red circle. Can anyone help if it is a setting issue or anything i can try myself to fix this.
I would call my dealer and get it in warranty should cover it.
 
1 - 12 of 12 Posts
Top