2019 Chevy Blazer Forum banner

41 - 60 of 65 Posts

·
Registered
Joined
·
3 Posts
Report any issues or problems you are having with your 2019+ Chevy Blazer. We can compile a list of the issues together and try to resolve them and keep them as a case study.
I purchased my 2019 RS on Dec 23, 2019, and my safety systems don't appear to be working property. My pedestrian alert goes off when someone is walking on the sidewalk, my collision avoidance goes off with cars in the opposite lanes and my lane departure only pulls on the steering wheel but no alert sounds. I had a 2013 Equinox that saved me several times but this one is quirky. I was told by my dealer that it's just the way it is. Anyone else having problems?
 

·
Registered
Joined
·
105 Posts
I purchased my 2019 RS on Dec 23, 2019, and my safety systems don't appear to be working property. My pedestrian alert goes off when someone is walking on the sidewalk, my collision avoidance goes off with cars in the opposite lanes and my lane departure only pulls on the steering wheel but no alert sounds. I had a 2013 Equinox that saved me several times but this one is quirky. I was told by my dealer that it's just the way it is. Anyone else having problems?
Have not seen this- but I havent had it long
 

·
Registered
Joined
·
6 Posts
I purchased my 2019 Blazer on Aug 19 2019 with 7 miles on the dash. Today is Oct 23 2019 ( 2 months and 4 days later) my odometer say I have 7044 miles and I need to change the oil. Never in my 50 some odd yrs of living have I purchase a brand new vehicle and needed an oil change within 2 months nor have I drove over 7000 miles in 2 months. Something is definitely wrong here. I live in Charleston, South Carolina. I drove to NYC once, drove to Columbia, SC 5 times 100 miles and the rest of the time I drove to the grocery store which is less than 10 miles or to my parents house 5 miles . I work from home. There is no way Possible this mileage is correct. I am at the dealership and they say numbers dont lie. Now, I dont know what numbers do but I do know these numbers are tainted. Just impossible. I dont know if its the dealer or the factory but i know its not me. Has anyone notice this problem or have any kind of input.
[/QUOTE
I purchased my 2019 Blazer on Aug 19 2019 with 7 miles on the dash. Today is Oct 23 2019 ( 2 months and 4 days later) my odometer say I have 7044 miles and I need to change the oil. Never in my 50 some odd yrs of living have I purchase a brand new vehicle and needed an oil change within 2 months nor have I drove over 7000 miles in 2 months. Something is definitely wrong here. I live in Charleston, South Carolina. I drove to NYC once, drove to Columbia, SC 5 times 100 miles and the rest of the time I drove to the grocery store which is less than 10 miles or to my parents house 5 miles . I work from home. There is no way Possible this mileage is correct. I am at the dealership and they say numbers dont lie. Now, I dont know what numbers do but I do know these numbers are tainted. Just impossible. I dont know if its the dealer or the factory but i know its not me. Has anyone notice this problem or have any kind of input.
I wondered about my mileage as well. I got my Blazer in June and have over 10,000 miles on it. I live 3 miles from work. Very strange.
 

·
Registered
Joined
·
38 Posts
I purchased my 2019 Blazer on Aug 19 2019 with 7 miles on the dash. Today is Oct 23 2019 ( 2 months and 4 days later) my odometer say I have 7044 miles and I need to change the oil. Never in my 50 some odd yrs of living have I purchase a brand new vehicle and needed an oil change within 2 months nor have I drove over 7000 miles in 2 months. Something is definitely wrong here. I live in Charleston, South Carolina. I drove to NYC once, drove to Columbia, SC 5 times 100 miles and the rest of the time I drove to the grocery store which is less than 10 miles or to my parents house 5 miles . I work from home. There is no way Possible this mileage is correct. I am at the dealership and they say numbers dont lie. Now, I dont know what numbers do but I do know these numbers are tainted. Just impossible. I dont know if its the dealer or the factory but i know its not me. Has anyone notice this problem or have any kind of input.
This is very alarming. Thanks so much for sharing. I keep a gas log on my current vehicle as well as having State Farm’s Drive Safe & Save toggle that keeps track of my driving. Between these two things, and when I purchase my Blazer, I should be able to back up any argument at the dealer if I experience something like this and they don't believe me.

Prematurely aging the vehicle/warranty is not cool, GM.
 

·
Registered
Joined
·
105 Posts
This is very alarming. Thanks so much for sharing. I keep a gas log on my current vehicle as well as having State Farm’s Drive Safe & Save toggle that keeps track of my driving. Between these two things, and when I purchase my Blazer, I should be able to back up any argument at the dealer if I experience something like this and they don't believe me.

Prematurely aging the vehicle/warranty is not cool, GM.
i honestly doubt they would be stupid enough to set this up as a secret feature. Thats a lawsuit waiting to happen. These vehicles are very reliant on the main electrical system and it seems to me some wierd stuff is happening as a result.
 

·
Registered
Joined
·
38 Posts
I purchased my 2019 Blazer on Aug 19 2019 with 7 miles on the dash. Today is Oct 23 2019 ( 2 months and 4 days later) my odometer say I have 7044 miles and I need to change the oil. Never in my 50 some odd yrs of living have I purchase a brand new vehicle and needed an oil change within 2 months nor have I drove over 7000 miles in 2 months. Something is definitely wrong here. I live in Charleston, South Carolina. I drove to NYC once, drove to Columbia, SC 5 times 100 miles and the rest of the time I drove to the grocery store which is less than 10 miles or to my parents house 5 miles . I work from home. There is no way Possible this mileage is correct. I am at the dealership and they say numbers dont lie. Now, I dont know what numbers do but I do know these numbers are tainted. Just impossible. I dont know if its the dealer or the factory but i know its not me. Has anyone notice this problem or have any kind of input.
Is your system possibly configured in metric? This may account for the larger than expected numbers. If it is, I'm pretty sure you can change it to U.S. standard.
 

·
Registered
Joined
·
105 Posts
My fuel gauge problem has resurfaced.....this is after the dealer did extensive work to try and correct the issue, including installing a new float. Gauge read empty- the vehicle only took 15 gallons before pump shut down. Got back in the car and the gauge reads half a tank! What the hell is going on here? I dont see a TSB for this and it appears no one else here has had this issue.
 

·
Registered
Joined
·
33 Posts
My 2020 RS is three months old and is in the shop for the second time and a total of nine days so far. Dash & radio would not shut off after leaving vehicle. Driver window regulator (motor) replaced. Passenger mirror camera stopped working, which they broke trying to fix the camera; I thought just the glass, but SA said they have to paint it then install it. Also agree with other poster that said safety features not working correctly (collision avoidance).

Really regret this purchase. Needed reliable transportation and am now in a rental car. :(
 

·
Registered
Joined
·
105 Posts
My 2020 RS is three months old and is in the shop for the second time and a total of nine days so far. Dash & radio would not shut off after leaving vehicle. Driver window regulator (motor) replaced. Passenger mirror camera stopped working, which they broke trying to fix the camera; I thought just the glass, but SA said they have to paint it then install it. Also agree with other poster that said safety features not working correctly (collision avoidance).

Really regret this purchase. Needed reliable transportation and am now in a rental car. :(
Was your radio replaced? Mine was and the issues went away.
 

·
Registered
Joined
·
105 Posts
My fuel gauge problem has resurfaced.....this is after the dealer did extensive work to try and correct the issue, including installing a new float. Gauge read empty- the vehicle only took 15 gallons before pump shut down. Got back in the car and the gauge reads half a tank! What the hell is going on here? I dont see a TSB for this and it appears no one else here has had this issue.
Today my dealer told me he got a proposed fix to the fuel gauge issue- a new driver's side level sensor- which is on national backorder of course. Im surprised no other owners in the forum have experienced this issue. he said the fact its on backorder suggests its widespread.
 

·
Registered
Joined
·
33 Posts
Was your radio replaced? Mine was and the issues went away.
No, they said it was the window motor causing the issue with the radio. Sounds strange at first, but the driver door switch is connected to the window motor which is connected to the LIN data bus. That is how they explained it, but then again they have broken more than they have fixed, the radio issue went away the day they ordered the part and has been fine since.
 

·
Registered
Joined
·
1 Posts
I am looking for help! I purchased a brand new 2019 Chevy Blazer 6 months ago, in Sep, 2019. I recently heard a strange noise from front right, like buzzing noise but not the same, when driving above 60 mph. I went to the store and played my recording of the noise. After several days, they called me to take my car. However, they still didn't find any problem. They said heard the noise in my recording. They have several technicians to check, but none of them can hear the noise in the car. I have no choice but take my car. When I drove home, I immediately heard the noise when I was on highway. My recording is attached (please remove the .pdf extension). Anyone please help!!!
 

Attachments

·
Registered
Joined
·
2 Posts
Auto Stop Feature

Just upgraded to a Blazer RS from a 2016 Chevy Cruze last month. My cruze also had a the auto stop feature, and turned the engine off when the vehicle came to a complete stop, and stayed off until I released my foot from the break peddle.

I've noticed on my Blazer that when I come to a complete stop and the auto-stop feature is initiated, regardless of wether or not I take my foot off the break peddle, the engine randomly starts after a minute or two.

Has anyone else had this issue? Wondering if its my Blazer or a new feature from Chevy that the auto-stop feature only turns your car off for a few minutes and then turns it back on.

thanks!
 

·
Registered
Joined
·
2 Posts
The parameters of start stop are why need to be read in owners manual . On our 2018 Traverse it comes back on if you release the brake if the voltage drops below roughly 12 volts or the transmission temp is above a certain temp. Don’t know if you were driving in heat with a/c cranked at night with headlights on that would be worse case for start stop to restart quickly.
 

·
Registered
Joined
·
105 Posts
The parameters of start stop are why need to be read in owners manual . On our 2018 Traverse it comes back on if you release the brake if the voltage drops below roughly 12 volts or the transmission temp is above a certain temp. Don’t know if you were driving in heat with a/c cranked at night with headlights on that would be worse case for start stop to restart quickly.
Yes, this version is more complex and will re-engage the engine under various circumstances. I had a vehicle with this feature (regal e-assist) and it rarely, if ever would restart engine- but the downside to this was that in the summer time the AC temp would drop after being at a stop for more than a few seconds. They have definitely updated the system.
 

·
Registered
Joined
·
1 Posts
I ha
Report any issues or problems you are having with your 2019+ Chevy Blazer. We can compile a list of the issues together and try to resolve them and keep them as a case study.
I have a 2019 blazer AWD and the suspension or breaks squeak constantly. Took to dealer. Said they can’t repeat problem. Happened to me again today all day. I have video. WhAt might it be before I go back and feel like an idiot with my video. Techs could be condescending.
 

·
Registered
Joined
·
105 Posts
I ha

I have a 2019 blazer AWD and the suspension or breaks squeak constantly. Took to dealer. Said they can’t repeat problem. Happened to me again today all day. I have video. WhAt might it be before I go back and feel like an idiot with my video. Techs could be condescending.
I had a squeak and I thought it was suspension but it turned out it was coming from the hatch- they made a fix that was posted in a TSB and the sound went away.
 
41 - 60 of 65 Posts
Top